summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Majewski2020-06-02 23:15:48 +0200
committerKevin Majewski2020-06-02 23:15:48 +0200
commit285009fd9dec60d4515ccd0bdc3530247240b3b7 (patch)
tree791a14f4321315d7b99c03e10ea5195dc18b1894 /PKGBUILD
downloadaur-285009fd9dec60d4515ccd0bdc3530247240b3b7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a5219732efe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=gnome-sound-recorder-git
+_pkgname=gnome-sound-recorder
+pkgver=3.34.0+99+gf45ae48
+pkgrel=1
+pkgdesc="A utility to make simple audio recording from your GNOME desktop"
+url="https://wiki.gnome.org/Apps/SoundRecorder"
+arch=(any)
+license=(GPL2)
+depends=('gtk3' 'gjs' 'gst-plugins-good' 'gst-plugins-base' 'libhandy')
+makedepends=('gobject-introspection' 'git' 'meson')
+provides=('gnome-sound-recorder')
+conflicts=('gnome-sound-recorder')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-sound-recorder.git#commit=$_commit")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}