summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Edson2023-12-20 16:19:21 -0800
committerJason Edson2023-12-20 16:19:21 -0800
commitb9f1a34026f66a2fc65e13268701d2bc6e2b30d3 (patch)
tree1df5e59ab0d3907d014d3d0ac928952dadd0488e /PKGBUILD
parent2e34ba8a0a1926755460781c690881f2efd6f581 (diff)
downloadaur-gnome-terminal-fedora.tar.gz
Add missing depend and clean up meson options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 034c57ebaade..bfb6f0586b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
pkgver=3.50.1
-pkgrel=1
+pkgrel=2
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
@@ -16,8 +16,9 @@ arch=(
'x86_64'
)
depends=(
- 'vte3-notification>=0.74.0'
+ 'libhandy'
'gsettings-desktop-schemas'
+ 'vte3-notification>=0.74.0'
)
makedepends=(
'git'
@@ -62,11 +63,14 @@ prepare () {
}
build() {
- arch-meson build gnome-terminal \
- -D b_lto=false \
- -D docs=true \
- -D nautilus_extension=true \
- -D search_provider=true
+ local meson_options=(
+ -D b_lto=false
+ -D docs=true
+ -D nautilus_extension=true
+ -D search_provider=true
+ )
+
+ arch-meson build gnome-terminal "${meson_options[@]}"
meson compile -C build
}