summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIppytraxx2015-10-18 22:45:08 +0200
committerIppytraxx2015-10-18 22:45:08 +0200
commitd17d2df97fee21bd807859a6c89265b3d19a91dc (patch)
tree7973c38e74eb3a782e041a716a9f906f4a09f0a6 /PKGBUILD
downloadaur-d17d2df97fee21bd807859a6c89265b3d19a91dc.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26c5f7aebf22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vincent <ippytraxx@installgentoo.com>
+
+pkgname=gnome-twitch
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Enjoy Twitch on your GNU/Linux desktop"
+arch=('i686' 'x86_64')
+url="https://github.com/Ippytraxx/gnome-twitch"
+license=('GPL3')
+makedepends=('git' 'meson')
+depends=('gtk3' 'libsoup' 'json-glib' 'gstreamer' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'clutter-gst' 'clutter-gtk')
+conflicts=('gnome-twitch-git')
+install=gnome-twitch.install
+source=("https://github.com/Ippytraxx/gnome-twitch/archive/v${pkgver}.tar.gz")
+md5sums=('1047adaf29d2c948b68162d129a19fed')
+
+build()
+{
+ ls
+ cd "${pkgname}-${pkgver}"
+ mkdir build
+ meson . build
+ cd build
+ ninja
+}
+
+package()
+{
+ cd "${pkgname}-${pkgver}"
+ cd build
+ mesonconf -Dprefix=/usr
+ mesonconf -Dtype=release
+ DESTDIR="$pkgdir" ninja install
+}