summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Rauter2018-09-06 12:48:18 +0200
committerGabriel Rauter2018-09-06 12:48:18 +0200
commitb73914b51086515453e5f6a495a680fd17317468 (patch)
treea2362c56da6b3b41f8b02fe4d2c3be854df30e1e /PKGBUILD
parentbc954326c1a3468c5f26a0e31adb6055dfcd4a29 (diff)
downloadaur-b73914b51086515453e5f6a495a680fd17317468.tar.gz
fix building with vala >= 0.42
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57ab96258a15..8847474a6963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gnome-usage
pkgname=$_pkgname-git
-pkgver=3.28.0.8.gd3af0a0
+pkgver=3.28.0.26.g3e1b5bf
pkgrel=1
pkgdesc="GNOME application to view information about use of system resources"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -14,14 +14,20 @@ makedepends=(git meson vala)
optdepends=('accountsservice: show user tags for processes')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git"
+ "0001-Fix-build-with-vala-0.42.patch")
+sha256sums=('SKIP'
+ '9ffe8de8386f5f4aaadea3bca74509b38649ff98124e0f9b7dd37580c854ec34')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/^v//;s/-/./g;s/_/./g;'
}
+prepare() {
+ git -C $_pkgname apply $srcdir/0001-Fix-build-with-vala-0.42.patch
+}
+
build() {
arch-meson $_pkgname build
ninja -C build