summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Rauter2018-04-25 13:02:21 +0200
committerGabriel Rauter2018-04-25 13:09:32 +0200
commitbc954326c1a3468c5f26a0e31adb6055dfcd4a29 (patch)
treed446b238e0eac2bf3bf037a6929fcc80490d5db7 /PKGBUILD
parente7b2963aa063d8742cebcfe4c1264a8dbf31b6f7 (diff)
downloadaur-bc954326c1a3468c5f26a0e31adb6055dfcd4a29.tar.gz
port changes from gnome-usage community repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a3da99f1319..57ab96258a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,30 @@
_pkgname=gnome-usage
pkgname=$_pkgname-git
-pkgver=3.28.0
+pkgver=3.28.0.8.gd3af0a0
pkgrel=1
-pkgdesc="A nice way to view information about use of system resources"
+pkgdesc="GNOME application to view information about use of system resources"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://wiki.gnome.org/Apps/Usage"
-license=('GPL3')
-depends=('gtk3' 'libgtop')
-makedepends=('git' 'vala' 'gobject-introspection' 'meson')
-optdepends=('accountsservice: support for process user tags')
+license=(GPL3)
+depends=(gtk3 libgtop)
+makedepends=(git meson vala)
+optdepends=('accountsservice: show user tags for processes')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe | sed 's/^v//;s/-/./g;s/_/./g;'
+ cd $_pkgname
+ git describe --tags | sed 's/^v//;s/-/./g;s/_/./g;'
}
build() {
- rm -rf build
- arch-meson "$_pkgname" build
- ninja -v -C build
+ arch-meson $_pkgname build
+ ninja -C build
}
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C build install
}
-
-# vim:set ts=2 sw=2 et: