summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Majewski2020-03-10 10:58:45 +0100
committerKevin Majewski2020-03-10 10:58:45 +0100
commit8b3d6baf7c4a517702fe3c315641402e6c1a4e23 (patch)
tree3bbe7a283c93d38aa8e188cc99f392b94d4e74bd /PKGBUILD
downloadaur-gnome-video-effects-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..327d4ca4b00e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=gnome-video-effects-git
+_pkgname=gnome-video-effects
+pkgver=0.5.0+7+g98cd0b2
+pkgrel=1
+pkgdesc="Collection of GStreamer effects for GNOME"
+arch=(any)
+url="https://gitlab.gnome.org/GNOME/gnome-video-effects"
+license=(GPL2)
+depends=('gst-plugins-good' 'gst-plugins-bad' 'frei0r-plugins')
+makedepends=('meson' 'git')
+provides=('gnome-video-effects')
+conflicts=('gnome-video-effects')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-video-effects.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+# vim:set ts=2 sw=2 et: