summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2020-06-05 19:15:28 +0200
committerStephan Springer2020-06-05 19:15:28 +0200
commitd18586e300cc07c499df157407ed6d7e14bb31ae (patch)
tree2230e07289cd09959d1a6082624252e2acbf2d11 /PKGBUILD
parent59d83840dd1288d04f1cfdc522da970a68fece83 (diff)
downloadaur-d18586e300cc07c499df157407ed6d7e14bb31ae.tar.gz
remove branch restriction and update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3d604c2b248..5e9891638af0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gns3-gui
pkgname="$_pkgname"-git
-pkgver=v2.1.9.r25.g3000a9aa
+pkgver=v2.2.9.r0.g2530bf97
pkgrel=1
pkgdesc='GNS3 network simulator. Graphical user interface package.'
arch=('any')
@@ -13,13 +13,23 @@ groups=('gns3')
provides=('gns3-gui')
conflicts=('gns3-gui')
makedepends=('git' 'python-setuptools')
-depends=('python-jsonschema' 'gns3-converter' 'python-raven' 'python-psutil'
- 'python-pyqt5' 'python-sip' 'qt5-svg' 'qt5-websockets' 'desktop-file-utils')
-optdepends=('gns3-server-git: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.'
- 'dynamips: Cisco router emulator.'
- 'xterm: Default terminal emulator for CLI management of virtual instances.'
- 'wireshark-gtk: Live packet capture.')
-source=("$_pkgname::git+git://github.com/GNS3/$_pkgname.git#branch=2.1"
+depends=(
+ 'desktop-file-utils'
+ 'gns3-converter'
+ 'python-distro'
+ 'python-jsonschema'
+ 'python-psutil'
+ 'python-pyqt5'
+ 'python-sentry_sdk'
+ 'python-sip'
+ 'qt5-svg'
+ 'qt5-websockets'
+)
+optdepends=(
+ 'gns3-server: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.'
+ 'xterm: Default terminal emulator for CLI management of virtual instances.'
+ 'wireshark-gtk: Live packet capture.')
+source=("$_pkgname::git+git://github.com/GNS3/$_pkgname.git"
'gns3.desktop')
sha256sums=('SKIP'
'51e6db5b47e6af3d008d85e8c597755369fafb75ddb2af9e79a441f943f4c166')
@@ -29,6 +39,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ sed -i -e 's|^psutil==5\.6\.6$|psutil>=5.6.6|' requirements.txt
+}
+
build() {
cd "$_pkgname"
python setup.py build