summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2020-06-05 18:40:18 +0200
committerStephan Springer2020-06-05 18:40:18 +0200
commit6c2ba188cc4300fa03cea478625a7926f72e0f83 (patch)
tree57401f0d9028d6bb84a8682820cfefc84bd87a68 /PKGBUILD
parentd9a583cd34c7f2835d6451dad4769df420f18acc (diff)
downloadaur-6c2ba188cc4300fa03cea478625a7926f72e0f83.tar.gz
update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25edd905d0ac..49338071150e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,38 @@
pkgname=gns3-server
pkgver=2.2.9
-pkgrel=1
+pkgrel=2
pkgdesc='GNS3 network simulator, Server package'
arch=('x86_64')
url='https://github.com/GNS3/gns3-server'
license=('GPL3')
groups=('gns3')
makedepends=('python-setuptools')
-depends=('python-jsonschema' 'python-aiohttp' 'python-aiohttp-cors'
- 'python-async_generator' 'python-aiofiles'
- 'python-yarl' 'python-jinja' 'python-raven' 'python-psutil'
- 'python-zipstream-gns3' 'python-prompt_toolkit' 'python-async-timeout'
- 'python-py-cpuinfo' 'busybox')
-optdepends=('dynamips: Cisco router emulator.'
- 'gns3-gui: graphical user interface for GNS3 server.'
- 'iouyap: Bridge IOU to UDP, TAP and Ethernet.'
- 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
- 'vpcs: Simple PC emulation for basic network operations.'
- 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.'
+depends=(
+ 'busybox'
+ 'python-aiofiles'
+ 'python-aiohttp'
+ 'python-aiohttp-cors'
+ 'python-async_generator'
+ 'python-async-timeout'
+ 'python-distro'
+ 'python-jinja'
+ 'python-jsonschema'
+ 'python-prompt_toolkit'
+ 'python-psutil'
+ 'python-py-cpuinfo'
+ 'python-sentry_sdk'
+ 'python-yarl'
+ 'python-zipstream-gns3'
+)
+optdepends=(
+ 'dynamips: Cisco router emulator.'
+ 'gns3-gui: graphical user interface for GNS3 server.'
+ 'iouyap: Bridge IOU to UDP, TAP and Ethernet.'
+ 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
+ 'libvirt: needed for the NAT cloud'
+ 'vpcs: Simple PC emulation for basic network operations.'
+ 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.'
)
install="$pkgname".install
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"