summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2018-09-10 12:38:30 +0200
committerStephan Springer2018-09-10 12:38:30 +0200
commit9b53ba2ee7aadbfb2ed52f412c7803b123b2ef52 (patch)
tree38c2a6860336ca849979eef69931fa1a9f2258fe /PKGBUILD
parent1b9db0fbca65fb038a14c097344567888394a9a6 (diff)
downloadaur-9b53ba2ee7aadbfb2ed52f412c7803b123b2ef52.tar.gz
fix build errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebb2b2d33c92..f7637c032bf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gns3-server
pkgver=2.1.9
-pkgrel=1
+pkgrel=2
pkgdesc='GNS3 network simulator, Server package'
arch=('x86_64')
url='https://github.com/GNS3/gns3-server'
@@ -28,6 +28,11 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
sha256sums=('2255fd3fd2eb7756f58d8f1b60e32d24899a14ca471de1ae03f6db2d8cd00b4f'
'b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f')
+prepare() {
+ cd "$pkgname-$pkgver"
+ find . -type f -print0 | xargs -r0 sed -i -e 's/asyncio.async(/asyncio.ensure_future(/g'
+}
+
build() {
cd "$pkgname-$pkgver"
python setup.py build