summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseph Brains2018-07-02 12:06:31 +0300
committerJoseph Brains2018-07-02 12:06:31 +0300
commitacfd44f51323a63507ee073ecdeb6f0fd22d7daf (patch)
treee3ee8956828e1a230a99cd2912958ea7db55ac81 /PKGBUILD
parent08969e93ea7efd5ec5f00fa36d6793e22be831fc (diff)
downloadaur-acfd44f51323a63507ee073ecdeb6f0fd22d7daf.tar.gz
remove python-typing as dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 997dd57cfe17..9415a4a2ab5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gns3-server
pkgname=${_pkgname}-git
pkgver=2.1.8
-pkgrel=2
+pkgrel=3
pkgdesc='GNS3 network simulator. Server package.'
arch=('any')
url="https://github.com/GNS3/${_pkgname}"
@@ -12,7 +12,7 @@ replaces=('gns3-server')
provides=('gns3-server')
conflicts=('gns3-server')
makedepends=('python-setuptools')
-depends=('python-jsonschema>=2.4.0' 'python-jinja>=2.7.3' 'python-raven>=5.23.0' 'python-psutil>=3.0.0' 'python-zipstream-gns3' 'python-typing' 'python-yarl-gns3' 'python-aiohttp-gns3' 'python-aiohttp-cors-gns3' 'python-prompt_toolkit-gns3' 'python-async-timeout-gns3')
+depends=('python-jsonschema>=2.4.0' 'python-jinja>=2.7.3' 'python-raven>=5.23.0' 'python-psutil>=3.0.0' 'python-zipstream-gns3' 'python-yarl-gns3' 'python-aiohttp-gns3' 'python-aiohttp-cors-gns3' 'python-prompt_toolkit-gns3' 'python-async-timeout-gns3')
optdepends=('dynamips: Cisco router emulator.'
'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
'vpcs: Simple PC emulation for basic network operations.'
@@ -25,9 +25,14 @@ source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${_pkgname}/archi
sha256sums=('8bccf2ba16832743e0743f11fe19f506172af07c68d2eae156ea1b946415b1a0'
'd145c7a4b7163aecd91b71a0769130d62beb5f4381fe5437774f6b4477a3fa48')
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ sed -i '/^typing/d' requirements.txt
+}
+
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python3 setup.py install --root=${pkgdir} --optimize=1
- install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
- install -Dm644 ${srcdir}/${_pkgname}@.service ${pkgdir}/usr/lib/systemd/system/${_pkgname}@.service
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python3 setup.py install --root=${pkgdir} --optimize=1
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
+ install -Dm644 ${srcdir}/${_pkgname}@.service ${pkgdir}/usr/lib/systemd/system/${_pkgname}@.service
}