summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2021-01-10 22:52:07 +1000
committerMark Blakeney2021-01-10 22:52:07 +1000
commit6095b44f34ef5c8ea78374009038b3b4bd05f128 (patch)
tree04a2039d4012ad15ff86986dd03cb7933458fbe7 /PKGBUILD
downloadaur-6095b44f34ef5c8ea78374009038b3b4bd05f128.tar.gz
Initial version 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27f1ca35e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=gnucash-asx-fetch
+pkgver=1.2
+pkgrel=1
+pkgdesc="Utility to fetch and add current ASX prices to one or more gnucash files"
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python>=3.6")
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha1sums=('985b8dad8beacae3f5c6d3c52ed3380f4f0aa0fc')
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: