summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorb3niup2015-01-06 17:23:52 +0100
committerb3niup2015-06-14 03:37:16 +0200
commitec57c9f1485aff6cc70e51810eead5fc70963900 (patch)
tree2fc58d34b68c218ae4938a865af2d4f726074c6a /PKGBUILD
parentfd09c575891517a49710b7ebfd7f7a2e19e9be54 (diff)
downloadaur-ec57c9f1485aff6cc70e51810eead5fc70963900.tar.gz
Added custom _pkgname variable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ac9c5d1b8f8..9c61ab36929b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Benedykt 'b3niup' PrzybyƂo <b3niup@gmail.com>
pkgname=gnucash-xbt
+_pkgname=gnucash
pkgver=2.6.5
pkgrel=1
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
@@ -13,16 +14,16 @@ optdepends=('evince: for print preview'
'perl-finance-quote: for stock information lookups'
'perl-date-manip: for stock information lookups')
options=('!makeflags' '!emptydirs')
-conflicts=('gnucash', 'gnucash-devel')
+conflicts=('gnucash' 'gnucash-devel')
provides=('gnucash')
install=gnucash.install
-source=("http://downloads.sourceforge.net/sourceforge/gnucash/gnucash-${pkgver}.tar.bz2"
+source=("http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2"
"xbt.patch")
sha1sums=('c9a5184603e41c6582f8342d4be9e392eceef33f'
'3556218003a0caa823ea87c8c19e2a8e99c244d5')
prepare() {
- cd "${srcdir}/gnucash-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
}
@@ -34,7 +35,7 @@ build() {
}
package() {
- cd "${srcdir}/gnucash-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
cd src/doc/design
make DESTDIR="${pkgdir}" install-info