summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrufo2019-03-03 12:57:29 +0000
committergrufo2019-03-03 12:57:29 +0000
commitbc8bd1d0faf106999273c945f48a34a5b1e3b23d (patch)
tree3d21763dd9514cff57226d77d7ca70a8eb6bad66 /PKGBUILD
parent6c946b340579c55f5e00ee5fb60b6486d1ed1d1e (diff)
downloadaur-bc8bd1d0faf106999273c945f48a34a5b1e3b23d.tar.gz
New git revision (r27347.2d928ee05)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cef698f6634..9aad61af8acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='gnunet-git'
_appname='gnunet'
-pkgver='0.11.0'
+pkgver='0.11.0.r27347.2d928ee05'
pkgrel=1
pkgdesc="A framework for secure peer-to-peer networking"
arch=('x86_64')
@@ -14,16 +14,15 @@ url="http://gnunet.org"
license=('GPL')
provides=("${_appname}")
conflicts=("${_appname}")
-depends=('libextractor' 'sqlite' 'gnurl'
- 'libmicrohttpd' 'jansson')
+depends=('gmp' 'libgcrypt' 'libextractor' 'sqlite' 'gnurl'
+ 'libmicrohttpd' 'libunistring' 'libidn' 'jansson')
makedepends=('gettext' 'pkgconfig' 'autoconf' 'fakeuser-git'
- 'bluez-libs' 'python2' 'glpk' 'libpulse' 'opus')
+ 'bluez-libs' 'python' 'glpk' 'libpulse' 'opus')
optdepends=('bluez-libs'
- 'python2'
+ 'python'
'glpk'
'libpulse'
- 'opus'
- 'python2-zbar')
+ 'opus')
install='gnunet.install'
backup=('etc/gnunetd.conf')
options=('!makeflags')
@@ -36,9 +35,6 @@ md5sums=('SKIP'
_fakeadd_error() {
- echo "NOTE: makepkg -R is not supported because it does not load libfakeuser."
- echo " If pass -R, you will always see the following error message."
- echo
echo "You must have a 'gnunet' user and group, and additionally a 'gnunetdns' group in"
echo 'your system prior to building this package.'
echo
@@ -65,14 +61,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_appname}"
-
-
- # zbar (required by gnunet-qr) only has bindings for python2, so we have to use python2
- # Not sure whether other parts of Gnunet fully support Python v3.0. It does build with v3.
- # NOTE: can't override in aclocal.m4 (that file is autogenerated)
- _redefine_py="m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python2])"
- sed -i "0,/^AM_PATH_PYTHON.*/s/^AM_PATH_PYTHON.*/$_redefine_py\n&/" configure.ac
-
autoreconf -fi
sed -i 's|contrib doc|doc|' Makefile.*
[ -f Makefile ] || ./configure --prefix=/usr \