summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2018-08-22 20:25:42 -0400
committerredfish2018-08-22 20:29:02 -0400
commitda62de7e0819a75024c297b112babe7882c155e8 (patch)
tree1ba3a0e79d3b81327cd6bd8dfcf1e23ede5d449b /PKGBUILD
parenteb33dbd483c4828f64e67cbb6c52fdb2b4103f26 (diff)
downloadaur-da62de7e0819a75024c297b112babe7882c155e8.tar.gz
switch to python2 because zbar only works with v2
zbar is optional (for gnunet-qr), but I'm reluctant to only change python version for that script and not for other scripts. But, could do that, in order to not retard everything to v2 because of one optional dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a34d041d601..edb8931b711d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,9 @@ conflicts=("${_appname}")
depends=('libextractor' 'sqlite' 'gnurl'
'libmicrohttpd' 'jansson')
makedepends=('gettext' 'pkgconfig' 'autoconf' 'fakeuser-git'
- 'bluez-libs' 'python' 'glpk' 'libpulse' 'opus')
+ 'bluez-libs' 'python2' 'glpk' 'libpulse' 'opus')
optdepends=('bluez-libs'
- 'python'
+ 'python2'
'glpk'
'libpulse'
'opus'
@@ -66,8 +66,12 @@ prepare() {
cd "${srcdir}/${_appname}"
- # zbar only has bindings for python2
- sed -i '1s/python/python2/' gnunet/src/util/gnunet-qr
+
+ # zbar (required by gnunet-qr) only has bindings for python2, so we have to use python2
+ # Not sure whether other parts of Gnunet fully support Python v3.0. It does build with v3.
+ # NOTE: can't override in aclocal.m4 (that file is autogenerated)
+ _redefine_py="m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python2])"
+ sed -i "0,/^AM_PATH_PYTHON.*/s/^AM_PATH_PYTHON.*/$_redefine_py\n&/" configure.ac
autoreconf -fi
sed -i 's|contrib doc|doc|' Makefile.*