summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2018-08-22 19:41:16 -0400
committerredfish2018-08-22 20:29:02 -0400
commiteb33dbd483c4828f64e67cbb6c52fdb2b4103f26 (patch)
tree1a598f4cd8c61eb09f656da64fdb14f0b7e7c8bc /PKGBUILD
parenta66f8515be549984ff1aa4c84221d7b5d5021e2b (diff)
downloadaur-eb33dbd483c4828f64e67cbb6c52fdb2b4103f26.tar.gz
deps: add zbar for gnunet-qr as optional dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e09480f5f11..2a34d041d601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,8 @@ optdepends=('bluez-libs'
'python'
'glpk'
'libpulse'
- 'opus')
+ 'opus'
+ 'python2-zbar')
install='gnunet.install'
backup=('etc/gnunetd.conf')
options=('!makeflags')
@@ -64,6 +65,10 @@ pkgver() {
prepare() {
cd "${srcdir}/${_appname}"
+
+ # zbar only has bindings for python2
+ sed -i '1s/python/python2/' gnunet/src/util/gnunet-qr
+
autoreconf -fi
sed -i 's|contrib doc|doc|' Makefile.*
[ -f Makefile ] || ./configure --prefix=/usr \