summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMeno Abels2016-12-14 17:47:38 +0100
committerMeno Abels2016-12-14 17:47:38 +0100
commit1dd06dbfaf9acc21d2284ad30b21149e62ad7142 (patch)
tree070dce2f12fc99f3518df32a956b5f59c7da4c49 /PKGBUILD
downloadaur-1dd06dbfaf9acc21d2284ad30b21149e62ad7142.tar.gz
* initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9cd3252e820
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# GnuPG2 GIT version
+# Maintainer: alphazo@gmail.com
+# Based on official package maintained by Tobias Powalowski <tpowa@archlinux.org>
+# Cleanup from @holos
+
+_gitname=gnupg
+pkgname=gnupg-clavator
+pkgver=2.1.16+clavator
+pkgrel=1
+pkgdesc="GNU Privacy Guard 2 - a PGP replacement tool. Development version. Do not use in production environments. Test new ECC algorithms by using \"gpg --full-gen-key --expert\""
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+depends=('libldap' 'curl' 'bzip2' 'zlib' 'libksba>=1.2' 'libgpg-error' 'libgcrypt'
+ 'pth' 'libusb-compat' 'libassuan' 'npth' 'texinfo' 'readline' 'pinentry')
+license=('GPL')
+url="http://www.gnupg.org/"
+makedepends=('git' 'ghostscript' 'transfig' 'automake')
+provides=("gnupg=${pkgver}" 'dirmngr')
+conflicts=('gnupg2' 'gnupg' 'dirmngr')
+install=${pkgname}.install
+source=("git://github.com/mabels/gnupg.git#branch=quick-keytocard")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+
+ git describe --tags | sed 's/gnupg-//;s/-/+/g'
+}
+
+build() {
+ cd "$_gitname"
+
+ ./autogen.sh --force
+
+ ./configure \
+ --enable-maintainer-mode \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/gnupg
+
+ make
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR=${pkgdir} install
+ ln -s gpg2 "$pkgdir/usr/bin/gpg"
+}
+
+# vim: ft=sh syn=sh et sw=2