summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven-Hendrik Haase2021-02-22 05:29:35 +0000
committerSven-Hendrik Haase2021-02-22 05:29:35 +0000
commit02c1796a206f369f5776cc7064aab024ff3a8010 (patch)
treef1c44d1a57f811d4c32b02e4de934dcaa3d5f6f5 /PKGBUILD
parent6618dff62c03a067d8ea589bc1b6c956447de39c (diff)
downloadaur-02c1796a206f369f5776cc7064aab024ff3a8010.tar.gz
upgpkg: 4.0.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a22920b50aee..3acbe9e1d3a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
pkgname=go-bindata
-pkgver=3.5.2
-pkgrel=2
+pkgver=4.0.0
+pkgrel=1
pkgdesc="A small utility which generates Go code from any file"
arch=('x86_64')
url='https://github.com/shuLhan/go-bindata'
@@ -11,22 +11,26 @@ license=('custom:CC0')
depends=('glibc')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/shuLhan/go-bindata/archive/v${pkgver}.tar.gz")
-sha512sums=('2e9a807445ed6ddfd681f6886503c116c8ceba6572f5a8b2cdbf78c585a476b5dfb0dc967b62f1510caef8e1e09db39043362e252da773272a79a7b257c9d275')
+sha512sums=('c6182dd5ac46e7febe272e8f59c5e5c76658d42584c5db10e7b188577fc56d7a26f1743fea328f149ae5628fa305ca98cb5f27a29cef270cd10ef806e0e149bc')
build() {
+ export GO111MODULE=off
export CGO_LDFLAGS="${LDFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd $pkgname-$pkgver
+ export GOPATH="$srcdir"
+ mkdir -p "$GOPATH"/src/github.com/shuLhan/
+ mv $pkgname-$pkgver $GOPATH/src/github.com/shuLhan/go-bindata
+ cd $GOPATH/src/github.com/shuLhan/go-bindata
go build ./cmd/...
}
package() {
- cd $pkgname-$pkgver
+ cd src/github.com/shuLhan/go-bindata
install -Dm755 "go-bindata" "${pkgdir}/usr/bin/go-bindata"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"