summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGergely Imreh2019-05-18 11:10:55 +0100
committerGergely Imreh2019-05-18 11:10:55 +0100
commitf9af36794e3dbd38730b47fe63283a3348b92ad5 (patch)
tree75a04129eef601f6fc86947d48b6737c350ae207 /PKGBUILD
parent69c01f65ec1d4d60f6ba11fd5bb3bd2ad08be16e (diff)
downloadaur-f9af36794e3dbd38730b47fe63283a3348b92ad5.tar.gz
Add missing dependency, and use precompiled proofs if no rustup
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d857f8b4442..3bad12cafe5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,14 @@
pkgname=go-filecoin
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='A decentralized storage network, full node implementation in Go'
_organization='filecoin-project'
url="https://github.com/$_organization/$pkgname"
arch=('x86_64')
license=('MIT' 'Apache-2.0')
-#makedepends=('git' 'go>=1.11.2' 'rust>=1.31.0' 'pkgconf' 'clang')
-makedepends=('git' 'go>=1.11.2' 'rustup' 'pkgconf' 'clang')
-optdepends=()
+makedepends=('git' 'go>=1.11.2' 'pkgconf' 'clang' 'jq')
+optdepends=('rustup: compiling proofs from scratch')
conflicts=("${pkgname}-git")
source=("git+https://github.com/filecoin-project/go-filecoin.git#tag=${pkgver}")
@@ -44,9 +43,11 @@ build() {
msg2 'Installing dependencies...'
cd "$GOPATH/src/github.com/${_organization}/${pkgname}"
- # Use precompiled versions of proofs here
- export FILECOIN_USE_PRECOMPILED_RUST_PROOFS=true
- export FILECOIN_USE_PRECOMPILED_BLS_SIGNATURES=yes
+ if ! command -v rustup > /dev/null; then
+ echo "No rustup, will be using precompiled rust proofs and bls signatures."
+ export FILECOIN_USE_PRECOMPILED_BLS_SIGNATURES=yes
+ export FILECOIN_USE_PRECOMPILED_RUST_PROOFS=yes
+ fi
make deps
msg2 'Building binary...'