summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuentin Retornaz2015-12-17 01:39:14 +0100
committerQuentin Retornaz2015-12-17 01:39:14 +0100
commit386f2c3a87c2b888d398c8bef7b69818d284ba64 (patch)
treef4f16414b815a13698f0c015e19b32424b0102b7 /PKGBUILD
downloadaur-386f2c3a87c2b888d398c8bef7b69818d284ba64.tar.gz
Go For It 1.4 release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8185fe4b0ec4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Quentin Retornaz <quentin dot retornaz at yahoo dot fr>
+# Contributor: Manuel Kehl <https://launchpad.net/~mank319, https://github.com/mank319/>
+
+pkgname=go-for-it
+pkgver=1.4
+pkgrel=1
+pkgdesc='A stylish to-do list with built-in productivity timer.'
+arch=('i686' 'x86_64')
+url='https://github.com/mank319/Go-For-It'
+license=('GPL3')
+depends=('gtk3' 'libnotify')
+optdepends=()
+makedepends=('vala' 'cmake')
+conflicts=('go-for-it-git' 'go-for-it-bzr')
+install=go-for-it.install
+source=(https://github.com/mank319/Go-For-It/archive/release_v1.4.tar.gz)
+sha256sums=('76201c6c047f8d3e3f86d0a607b4e2f0f723007e7ed3a0f778bcf3fe0e39c85b')
+
+prepare() {
+ mv ${srcdir}/Go-For-It-release_v${pkgver}/* ${srcdir}/
+}
+
+build() {
+ cd ${srcdir}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file