summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorObed N Munoz2017-08-25 15:54:57 -0500
committerObed N Munoz2017-08-25 16:05:15 -0500
commit92035ec7c93cbfb6304d96e6dd1bea0f7b32d9c4 (patch)
treeeaa928541f7d5c24d29ffd5d20311fdce29ee2f2 /PKGBUILD
parent262fc7ebe75c655c30e1330c51dcabba1e4f1a61 (diff)
downloadaur-92035ec7c93cbfb6304d96e6dd1bea0f7b32d9c4.tar.gz
Move to https://go.googlesource.com/go/ source
This aims to make it easier to generate latest tagged packages on official golang source code repository. This is based on: https://git.archlinux.org/svntogit/packages.git/?h=packages/go which is maintained by: Bartłomiej Piotrowski <bpiotrowski@archlinux.org> Signed-off-by: Obed N Munoz <obed.n.munoz@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD174
1 files changed, 43 insertions, 131 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5633aaa44e44..48c527711256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,158 +9,70 @@
# Contributor: Mike Rosset <mike.rosset@gmail.com>
# Contributor: Daniel YC Lin <dlin.tw@gmail.com>
# Contributor: John Luebs <jkluebs@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
pkgname=go-git
-epoch=1
-pkgver=1.9beta2.r553.ge11fd00629
+epoch=2
+pkgver=1.9
pkgrel=1
-provides=(go=1.9)
-conflicts=('go' 'go-hg')
-pkgdesc='Compiler and tools for the Go programming language from Google'
-arch=('x86_64' 'i686')
+pkgdesc='Core compiler tools for the Go programming language'
+arch=(i686 x86_64)
url='http://golang.org/'
-license=('BSD')
-depends=('perl' 'gawk')
-makedepends=('inetutils' 'git' 'go>=1.4')
-options=('!strip' 'staticlibs')
-optdepends=('mercurial: for fetching sources from mercurial repositories'
- 'git: for fetching sources from git repositories'
- 'bzr: for fetching sources from bazaar repositories'
- 'subversion: for fetching sources from subversion repositories')
-install="$pkgname.install"
-source=("$pkgname::git+https://github.com/golang/go.git")
+license=(BSD)
+makedepends=(git go)
+options=(!strip staticlibs)
+_commit=c8aec4095e089ff6ac50d18e97c3f46561f14f48
+source=(git+https://go.googlesource.com/go#commit=$_commit)
md5sums=('SKIP')
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed -r 's/^go//;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
+export GOOS=linux
+case "$CARCH" in
+ x86_64) export GOARCH=amd64 ;;
+ i686) export GOARCH=386 GO386=387 ;;
+esac
+export GOROOT_FINAL=/usr/lib/go
+export GOROOT_BOOTSTRAP=/usr/lib/go
build() {
- cd "$pkgname/src"
-
export GOROOT="$srcdir/$pkgname"
export GOBIN="$GOROOT/bin"
export GOPATH="$srcdir/"
- export GOROOT_FINAL=/usr/lib/go
- export GOROOT_BOOTSTRAP="$GOROOT_FINAL"
-
- #
- # Arch Linux normally does not enable SSE2 for i686 because of older CPUs.
- #
- # However, exceptions are made for:
- # * Chromium, which is not expected to be used on older i686 CPUs
- # * Julia, which requires SSE2
- #
- # Go is so slow that it is unusable on i686 when SSE2 is not enabled, so I am
- # also making an exception for Go.
- #
- # If you really want to build Go without SSE2 support, just uncomment the
- # following export and rebuild:
- #
- # export GO386=387
-
- # Enable ARM crosscompilation for linux
- export GOOS=linux
- export GOARCH=arm
-
- bash make.bash
-
- # Crosscompilation for various platforms (including linux)
- for os in linux; do # darwin freebsd windows; do
- for arch in amd64 386; do
- export GOOS="$os"
- export GOARCH="$arch"
- bash make.bash --no-clean
- done
- done
-
- GOOS=linux
- case "$CARCH" in
- x86_64) GOARCH=amd64 ;;
- i686) GOARCH=386 ;;
- esac
- $GOROOT/bin/go get -v -d golang.org/x/tools/cmd/godoc
- $GOROOT/bin/go build -o $srcdir/godoc golang.org/x/tools/cmd/godoc
- for tool in cover; do
- $GOROOT/bin/go get -v -d golang.org/x/tools/cmd/${tool}
- $GOROOT/bin/go build -o $GOROOT/pkg/tool/${GOOS}_${GOARCH}/${tool} golang.org/x/tools/cmd/${tool}
- done
+ cd $pkgname/src
+ ./make.bash --no-clean
}
check() {
- cd "$pkgname"
-
- export GO386=387
-
- export GOOS=linux
- if [ "$CARCH" == 'x86_64' ]; then
- export GOARCH=amd64
- elif [ "$CARCH" == 'i686' ]; then
- export GOARCH=386
- fi
-
export GOROOT="$srcdir/$pkgname"
export GOBIN="$GOROOT/bin"
- export PATH="$srcdir/$pkgname/bin:$PATH"
+ export PATH="$srcdir/$pkgname-$pkgver/bin:$PATH"
+ export GO_TEST_TIMEOUT_SCALE=2
+
+ # The cgo_test and race tests fail via run.bash but not if run manually.
+ # Assume that five "failed" messages are okay and just re-run failed tests.
+ cd $pkgname/src
+ ./run.bash --no-rebuild -v -v -v -k |& tee run.log
+ if (( $(grep -c Failed: run.log) > 5 )) && grep -q FAILED run.log; then
+ return 1
+ fi
- # TestSimpleMulticastListener will fail in standard chroot
- cd src && bash run.bash --no-rebuild || true
+ go tool dist test -v -v -v -run=^cgo_test$
+ go tool dist test -v -v -v -run=^race$
}
package() {
- cd "$pkgname"
+ cd $pkgbase
- export GOROOT="$srcdir/$pkgname"
- export GOBIN="$GOROOT/bin"
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib/go" "$pkgdir/usr/share/doc/go"
+ cp -a bin pkg src lib misc "$pkgdir/usr/lib/go"
+ cp -r doc/* "$pkgdir/usr/share/doc/go"
- install -Dm755 "$srcdir/godoc" "$pkgdir/usr/bin/godoc"
-
- install -Dm644 LICENSE \
- "$pkgdir/usr/share/licenses/go/LICENSE"
-
- mkdir -p \
- "$pkgdir/"{etc/profile.d,usr/{share/go,lib/go,lib/go/src,lib/go/site/src}}
-
- cp -r doc misc -t "$pkgdir/usr/share/go"
- ln -s /usr/share/go/doc "$pkgdir/usr/lib/go/doc"
- cp -a bin "$pkgdir/usr"
- cp -a pkg "$pkgdir/usr/lib/go"
- cp -a "$GOROOT/src" "$pkgdir/usr/lib/go/"
- cp -a "$GOROOT/src/cmd" "$pkgdir/usr/lib/go/src/cmd"
- cp -a "$GOROOT/lib" "$pkgdir/usr/lib/go/"
-
- install -Dm644 src/Make.* "$pkgdir/usr/lib/go/src"
-
- # Remove object files from target src dir
- find "$pkgdir/usr/lib/go/src/" -type f -name '*.[ao]' -delete
-
- # Fix for FS#32813
- find "$pkgdir" -type f -name sql.go -exec chmod -x {} \;
-
- # Remove all executable source files
- find "$pkgdir/usr/lib/go/src" -type f -executable -delete
-
- # This is to make go get code.google.com/p/go-tour/gotour and
- # then running the gotour executable work out of the box.
- ln -sf /usr/bin "$pkgdir/usr/lib/go/bin"
-
- # For FS#42660 / FS#42661 / gox
- install -Dm755 src/make.bash "$pkgdir/usr/lib/go/src/make.bash"
- install -Dm755 src/run.bash "$pkgdir/usr/lib/go/src/run.bash"
- cp -r misc/ "$pkgdir/usr/lib/go/"
-
- # For godoc
- install -Dm644 favicon.ico "$pkgdir/usr/lib/go/favicon.ico"
-
- rm -f "$pkgdir/usr/share/go/doc/articles/wiki/get.bin"
-
- # Is this required?
- #install -Dm644 VERSION "$pkgdir/usr/lib/go/VERSION"
-
- find "$pkgdir/usr/"{lib/go/pkg,bin} -type f -exec touch '{}' +
-}
+ ln -sf /usr/lib/go/bin/go "$pkgdir/usr/bin/go"
+ ln -sf /usr/lib/go/bin/gofmt "$pkgdir/usr/bin/gofmt"
+ ln -sf /usr/share/doc/go "$pkgdir/usr/lib/go/doc"
-# vim:set ts=2 sw=2 et:
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/go/LICENSE"
+
+ rm -rf "$pkgdir/usr/lib/go/pkg/bootstrap"
+ rm -rf "$pkgdir/usr/lib/go/pkg/tool/*/api"
+} \ No newline at end of file