summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author@RubenKelevra2020-05-14 00:12:27 +0200
committer@RubenKelevra2020-05-14 00:12:27 +0200
commitaf035b5c95be553643435b2c114d9ac7feedb23c (patch)
tree3bdc8b0181f80919822cf47ebbed7158c4c16f30 /PKGBUILD
parent50dce7239536eb1d6c0f7a9e3c1e189291a59d72 (diff)
downloadaur-af035b5c95be553643435b2c114d9ac7feedb23c.tar.gz
add sane defaults to service: pubsub+gc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db1f95ae72b0..28a84c3b80a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=go-ipfs
pkgname=$_pkgname-git
-pkgver=0.5.1.r89.gfa8c88b12
-pkgrel=3
+pkgver=0.5.1.r97.gfa8c88b12
+pkgrel=2
pkgdesc='A peer-to-peer hypermedia distribution protocol'
url="https://github.com/ipfs/$_pkgname"
arch=('i686' 'x86_64' 'armv7h')
@@ -56,7 +56,7 @@ build() {
package() {
cd "$srcdir/$_pkgname"
#avoid migrations on bootup (see #7269)
- sed -i 's/--migrate//g' misc/systemd/ipfs.service
+ sed -i 's/--migrate/--enable-gc --enable-pubsub-experiment --enable-namesys-pubsub/g' misc/systemd/ipfs.service
#increase timeouts (see #7283)
sed -i 's/MemorySwapMax=0/MemorySwapMax=0\n\nTimeoutStartSec=15min\nTimeoutStopSec=15min\nTimeoutAbortSec=15min/' misc/systemd/ipfs.service
install -Dm 755 cmd/ipfs/ipfs "$pkgdir/usr/bin/ipfs"