summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author@RubenKelevra2020-04-25 20:41:48 +0200
committer@RubenKelevra2020-04-25 20:41:48 +0200
commitbe82459e90f4c5cf3345192745585e0e9a9d58a3 (patch)
treee37fc72d826ec716427795850a8858d65aa87cc1 /PKGBUILD
parent03764689ff105f437ea2ed4e60b46b44da91806f (diff)
downloadaur-be82459e90f4c5cf3345192745585e0e9a9d58a3.tar.gz
changes build process according to the consense of the discussion on arch-dev-public
this version conflicts go-pie, to make sure you replace it from the system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0229c0c7876b..8b2a00ea7944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,17 @@
_pkgname=go-ipfs
pkgname=$_pkgname-git
-pkgver=0.5.0rc1.r26.g6cb3ca41d
-pkgrel=3
+pkgver=0.5.0rc4.r0.g116999a19
+pkgrel=1
pkgdesc='A peer-to-peer hypermedia distribution protocol'
url="https://github.com/ipfs/$_pkgname"
arch=('i686' 'x86_64' 'armv7h')
license=('MIT')
-makedepends=("go-pie>=2:1.14.2-1" git)
+makedepends=("go>=2:1.14.2-1" git)
optdepends=('fuse2: for mounting/advanced use'
'bash-completion: bash completion support')
provides=("$_pkgname")
-conflicts=("$_pkgname")
+conflicts=("$_pkgname" go-pie)
source=("git+${url}.git"
"ipfs.service"
"ipfs@.service")
@@ -30,14 +30,18 @@ pkgver() {
#VERSION=$(grep -E "^const CurrentVersionNumber = " version.go | awk '{ print $4 }' | sed 's/"//g')
VERSION=$(git tag | grep -vE "floodsub|sharding-pre" | grep -ve "-dev" | sed 's/-/~/g' | sort --version-sort --reverse | sed 's/~/-/g' | head -n1)
COUNT=$(git rev-list "$VERSION.." --count)
- CHKSUM=$(git rev-list "$VERSION.." | head -n1)
+ CHKSUM=$(git rev-list master | head -n1)
VERSION=$(echo "$VERSION" | sed 's/^v//' | sed 's/-//')
printf "%s.%s.%s" "$VERSION" "r$COUNT" "g${CHKSUM:0:9}"
}
build() {
cd "$srcdir/$_pkgname"
- make build
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ make GOFLAGS="-buildmode=pie -trimpath -modcacherw" build
}
package() {