summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkpcyrd2015-10-26 22:04:56 +0100
committerFrederik “Freso” S. Olesen2015-10-26 22:04:56 +0100
commitdc8603b448d411fa2cdde11f7d92f6c174744dfc (patch)
tree073bb85793f66981a8efb4e18308bd77730607dd /PKGBUILD
parent098647a0f539f6ae0884498b8292ba42c56c6827 (diff)
downloadaur-dc8603b448d411fa2cdde11f7d92f6c174744dfc.tar.gz
Some PKGBUILD updates by kpcyrd.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05efadda8cdb..f4dfb18bc602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,41 @@
# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
+# Contributor: kpcyrd <git@rxv.cc>
# Contributor: Ian Naval <ianonavy@gmail.com>
pkgname=go-ipfs
pkgver=0.3.8
pkgrel=1
-pkgdesc="global versioned p2p merkledag file system"
+pkgdesc='global versioned p2p merkledag file system'
+url='https://github.com/ipfs/$pkgname'
arch=('i686' 'x86_64' 'armv7h')
-url="https://github.com/ipfs/$pkgname"
license=('MIT')
makedepends=('go')
-optdepends=('fuse: for mounting/advanced use')
-conflicts=("$pkgname-git")
+optdepends=('fuse: for mounting/advanced use'
+ 'bash-completion: bash completion support')
source=("${url}/archive/v${pkgver}.tar.gz")
sha512sums=('d991714e8a0ed6111ed5585a59a964f4d16679b0c4d2af335592c742490c420f66ad2454e622dab952230675d336020a0f4747676a463ce2a9cff4dea5827e6b')
-build() {
- # Required for go get
- export GOPATH="$srcdir"
-
- # Make src directory for $GOPATH
- mkdir -p "$GOPATH/src"
+prepare() {
+ cd "${pkgname}-${pkgver}"
- mv "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$pkgname"
- cd "$GOPATH/src/$pkgname/cmd/ipfs"
+ mkdir -p .gopath/src/github.com/ipfs
+ ln -sf "$PWD" .gopath/src/github.com/ipfs/go-ipfs
+}
- msg2 'Installing dependencies...'
- go get -v ./...
+build() {
+ cd "${pkgname}-${pkgver}/cmd/ipfs"
+ export GOPATH="$PWD/../../.gopath"
- msg2 'Building binary...'
- go install -v
+ go build -v
}
package() {
- cd "$srcdir"
-
- install -dm755 "$pkgdir/usr/bin"
- install -m755 "$srcdir/bin/ipfs" "$pkgdir/usr/bin/ipfs"
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm 755 cmd/ipfs/ipfs "${pkgdir}/usr/bin/ipfs"
+ install -Dm 644 misc/completion/ipfs-completion.bash "${pkgdir}/etc/bash_completion.d/ipfs"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ README.md \
+ CHANGELOG.md
}