summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfzerorubigd2017-01-07 13:46:33 +0330
committerfzerorubigd2017-01-07 13:46:33 +0330
commit534fd3d3692fa199e2e2ca6b01f76b37591c4d03 (patch)
tree5c372747d622b992c36b529e662998a90db67731 /PKGBUILD
downloadaur-534fd3d3692fa199e2e2ca6b01f76b37591c4d03.tar.gz
initialize commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bcb3c52216c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname=go-outline-git
+pkgver=20161011.9_e785568
+pkgrel=1
+pkgdesc="Utility to extract JSON representation of declarations from a Go source file"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=(
+)
+makedepends=(
+ 'go'
+ 'git'
+)
+
+source=(
+ "git://github.com/lukehoban/go-outline.git"
+)
+
+md5sums=(
+ 'SKIP'
+)
+
+backup=(
+)
+
+conflicts=(
+)
+
+pkgver() {
+ cd "$srcdir/go-outline"
+ local date=$(git log -1 --format="%cd" --date=short | sed s/-//g)
+ local count=$(git rev-list --count HEAD)
+ local commit=$(git rev-parse --short HEAD)
+ echo "$date.${count}_$commit"
+}
+
+build() {
+ GOPATH=$srcdir
+ GOBIN=$srcdir/bin/
+ mkdir -p $srcdir/src
+ ln -sf $srcdir/go-outline $srcdir/src
+ cd $srcdir/src/go-outline
+ go get -v
+}
+
+package() {
+ find "$srcdir/bin/" -type f -executable | while read filename; do
+ install -DT "$filename" "$pkgdir/usr/bin/$(basename $filename)"
+ done
+}