summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2020-12-28 08:56:06 -0500
committerMario Finelli2020-12-28 08:56:06 -0500
commitc20afbecf0c95c7370c01bc661dbdfa7f815d439 (patch)
tree057ba823b11cecbbd92ca1164a7887e1ff32014f /PKGBUILD
parent2cb3de15d9f2622b109876dde8d19a12ed80203a (diff)
downloadaur-c20afbecf0c95c7370c01bc661dbdfa7f815d439.tar.gz
Bump to 4.2.0 and add shell completions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 868d963979b3..7b27dc89dcb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=go-yq
-pkgver=4.1.0
+pkgver=4.2.0
pkgrel=1
pkgdesc="portable command-line YAML processor"
arch=(x86_64)
@@ -11,7 +11,7 @@ depends=(glibc)
makedepends=(go)
conflicts=(yq)
source=(https://github.com/mikefarah/yq/archive/v${pkgver}/yq-${pkgver}.tar.gz)
-sha256sums=('2ff35db36b2d8226d181deb02b8e80ea7f6d4fbe04b7942fc5de2470e91b66d5')
+sha256sums=('19a75856c35cf99d7547faa5d00144b7a0d9e03ef04d10a20cd739dd8280ea7d')
prepare() {
cd yq-$pkgver
@@ -40,4 +40,11 @@ package() {
install -Dm0755 yq "$pkgdir/usr/bin/yq"
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ ./yq shell-completion bash | install -Dm0644 /dev/stdin \
+ "$pkgdir/usr/share/bash-completion/completions/yq"
+ ./yq shell-completion zsh | install -Dm0644 /dev/stdin \
+ "$pkgdir/usr/share/zsh/site-functions/_yq"
+ ./yq shell-completion fish | install -Dm0644 /dev/stdin \
+ "$pkgdir/usr/share/fish/vendor_completions.d/yq.fish"
}