summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2020-12-20 11:49:31 -0500
committerMario Finelli2020-12-20 11:49:31 -0500
commitd812352da29c553ce76f12508bbae3ac5ab993c7 (patch)
tree892e4545bf6658231eeb9617ec0d3debcd45d814 /PKGBUILD
parenta91c18fa9414b0d7ec3f9d76b34730133d4da272 (diff)
downloadaur-d812352da29c553ce76f12508bbae3ac5ab993c7.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f8a81821cd1..819486b4ef1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
pkgname=go-yq
pkgver=3.4.1
-pkgrel=1
-pkgdesc='portable command-line YAML processor'
+pkgrel=2
+pkgdesc="portable command-line YAML processor"
arch=(x86_64)
url=https://github.com/mikefarah/yq
license=(MIT)
+depends=(glibc)
makedepends=(go)
conflicts=(yq)
-source=(https://github.com/mikefarah/yq/archive/${pkgver}.tar.gz)
+source=(https://github.com/mikefarah/yq/archive/${pkgver}/yq-${pkgver}.tar.gz)
sha256sums=('73259f808d589d11ea7a18e4cd38a2e98b518a6c2c178d1ec57d9c5942277cb1')
prepare() {
cd yq-$pkgver
+ export GOPATH="$srcdir/gopath"
go mod vendor
}
@@ -24,6 +26,7 @@ check() {
build() {
cd yq-$pkgver
+ export GOPATH="$srcdir/gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -34,6 +37,7 @@ build() {
package() {
cd yq-$pkgver
- install -Dm755 yq "$pkgdir/usr/bin/yq"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0755 yq "$pkgdir/usr/bin/yq"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}