summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-02-09 10:37:37 +0100
committerL.G. Sarmiento2018-02-09 10:37:37 +0100
commitbfe6b09d285d74885eb1e2ff50cbfe0d37dbbd58 (patch)
tree16c23749ac376221e1b51309ac01493f18a4dc75 /PKGBUILD
parenta10a9bd82c4cfa2feb31c8a8db75dcfc101d1400 (diff)
downloadaur-bfe6b09d285d74885eb1e2ff50cbfe0d37dbbd58.tar.gz
ROOT 6.12 compilation issue fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3661a4c3cc5a..c98326904249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
pkgname=go4
_Pkgname=Go4
pkgver=5.2.0
-pkgrel=6
+pkgrel=7
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
-arch=('i686' 'x86_64')
-depends=('root=6.10.08' 'qt4')
+arch=('x86_64')
+depends=('root' 'qt4')
url="https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
@@ -33,6 +33,9 @@ prepare() {
#msg "fixing QGo4Widget.cpp:324:25: error: cannot convert ‘bool’ to ‘TGo4ViewPanel*’ in initialization"
#sed -i 's#TGo4ViewPanel\* res = false;#TGo4ViewPanel\* res = 0;#g' qt4/Go4GUI/QGo4Widget.cpp
+ msg "Fixing lack of Riosfwd.h from ROOT 6.12"
+ sed -i 's/#include "Riosfwd.h"/#include <iosfwd>/g' Go4EventServer/TGo4MbsFile.cxx
+
}
build() {
@@ -88,4 +91,8 @@ EOF
# for later maybe? uninstall and therefore remove packages
# PATH="${PATH/\/path\/to\/remove/}"
+ #/usr/include/root/Riosfwd.h:25:2: warning:
+ #warning "Riosfwd.h is deprecated. It will be removed in ROOT v6.12. Please use #include <iosfwd>, instead."
+
+ #sed -i 's#\$HOME#/usr#g' go
}