summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-03-23 20:05:58 +0100
committerL.G. Sarmiento2018-03-23 20:05:58 +0100
commitfbf0fa3c75fa13c530b9ed24a08d22364ca82920 (patch)
tree29992f89be669780e0be1bf1159b1dcb7b9c45a3 /PKGBUILD
parentf58d8cf0a143c73da502776ffe3c6a342d475ada (diff)
downloadaur-fbf0fa3c75fa13c530b9ed24a08d22364ca82920.tar.gz
updated to 5.3.0. Requires ROOT compiled with cxx14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 33 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06c13797066c..58c6a1e00899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
#
# Note to self. It is necessary to remove the current Go4 installation -if any- otherwise the compilation fails.
# Also, after removal, use a fresh terminal as go4login variables are no longer valid
-# Maybe just unsetting GO4SYS is enough(?)
+# Maybe just unsetting GO4SYS is enough(?) [looks like it is]
#
# It looks that ROOT6 requires the modification/definition of the variable ROOT_INCLUDE_PATH to /usr/include/go4
#
pkgname=go4
_Pkgname=Go4
-pkgver=5.2.0
+pkgver=5.3.0
pkgrel=8
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('x86_64')
@@ -16,9 +16,7 @@ depends=('root' 'qt5-base')
url="https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
-md5sums=('eede668b446e899da12487f182957ed0')
-
-_USEQT=5
+md5sums=('30d375a46fd5a1f13a15914eeec5629c')
prepare() {
@@ -27,15 +25,25 @@ prepare() {
cd go4-${pkgver}
# make it installation friendly
- sed -i 's#\$(GO4EXEPATH)#$(DESTDIR)&#g' Makefile
- sed -i 's#\$(GO4INCPATH)#$(DESTDIR)&#g' Makefile
- sed -i 's#\$(GO4LIBPATH)#$(DESTDIR)&#g' Makefile
- sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)&#g' Makefile
+ sed -i 's#\$(GO4EXEPATH)#$(DESTDIR)/&#g' Makefile
+ sed -i 's#\$(GO4INCPATH)#$(DESTDIR)/&#g' Makefile
+ sed -i 's#\$(GO4LIBPATH)#$(DESTDIR)/&#g' Makefile
+ sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)/&#g' Makefile
#/usr/include/root/Riosfwd.h:25:2: warning:
#warning "Riosfwd.h is deprecated. It will be removed in ROOT v6.12. Please use #include <iosfwd>, instead."
- msg "Go4 5.2.0 needs fixing lack of Riosfwd.h from ROOT 6.12"
- sed -i 's/#include "Riosfwd.h"/#include <iosfwd>/g' Go4EventServer/TGo4MbsFile.cxx
+ #msg "Go4 5.2.0 needs fixing lack of Riosfwd.h from ROOT 6.12"
+ #sed -i 's/#include "Riosfwd.h"/#include <iosfwd>/g' Go4EventServer/TGo4MbsFile.cxx
+ #
+ # this was fixed in 5.3.0
+ #
+ # #include "RVersion.h"
+ # #if ROOT_VERSION_CODE <= ROOT_VERSION(6,8,0)
+ # #include "Riosfwd.h"
+ # #else
+ # #include <iosfwd>
+ # #endif
+ #
}
@@ -44,8 +52,19 @@ build() {
cd go4-${pkgver}
make clean-bin
make clean
- ## rpath=false seemed to reduce que volume of warnings with ROOT6
- make prefix=/usr withqt=$_USEQT GO4_OS=Linux rpath=false withdabc=yes nodepend=1 debug=1 all || return 1
+
+ ##
+ # rpath=false seemed to reduce que volume of warnings with ROOT6
+ ##
+ ##
+ # go4 does NOT compile unless you compile ROOT with
+ #
+ # set (cxx14 ON CACHE BOOL "" FORCE)
+ # instead of
+ # set (cxx17 ON CACHE BOOL "" FORCE)
+ # in setting.cmake <-- ROOT package
+ ##
+ make prefix=/usr withqt=5 GO4_OS=Linux rpath=false withdabc=yes nodepend=1 debug=1 all || return 1
}
@@ -53,7 +72,7 @@ package() {
#install the package
cd go4-${pkgver}
- make DESTDIR="${pkgdir}/" install
+ make DESTDIR="${pkgdir}" install
#install the license
install -Dm644 "${srcdir}/go4-${pkgver}/Go4License.txt" "$pkgdir/usr/share/licenses/go4/Go4License.txt"