summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2016-11-02 10:04:09 +0100
committerL.G. Sarmiento2016-11-02 10:04:09 +0100
commitff22a63332f16cdd22d9cb0e29b1d07460006d67 (patch)
treeeaf0a0b078a2f2e11d7c03e6244fbd6361de2dad /PKGBUILD
parentddfc48393e35cde9bd7577c7060a97ee0df02d96 (diff)
downloadaur-ff22a63332f16cdd22d9cb0e29b1d07460006d67.tar.gz
after abi change in gcc, going back to root5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a3a0b137602..4d114861adcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@ pkgver=5.1.2
pkgrel=1
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('i686' 'x86_64')
-depends=('root' 'qt4')
+depends=('root5' 'qt4')
url="https://www.gsi.de/en/work/fairgsi/rare_isotope_beams/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
-source=("http://web-docs.gsi.de/~go4/download/${pkgname}-${pkgver}.tar.gz")
+source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
md5sums=('8083fe20cf894225039c4347de828f73')
-_USEQT=4
+_USEQT=4 # qt4 - Qt 4.6.x and higher (recommended) <-- from the source code 5.1.2
prepare() {
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
# make it installation friendly
sed -i 's#\$(GO4EXEPATH)#$(DESTDIR)/&#g' Makefile
@@ -33,28 +33,28 @@ prepare() {
build() {
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
make clean-bin
make clean
- make -j1 prefix=/usr withqt=$_USEQT GO4_OS=Linux rpath=true withdabc=no nodepend=1 debug=1 all || return 1
+ make prefix=/usr withqt=$_USEQT GO4_OS=Linux rpath=true withdabc=no nodepend=0 debug=1 all || return 1
}
package() {
#install the package
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
make DESTDIR=${pkgdir} install
#install the license
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/Go4License.txt" "$pkgdir/usr/share/licenses/${pkgname}/Go4License.txt"
+ install -Dm644 "${srcdir}/go4-${pkgver}/Go4License.txt" "$pkgdir/usr/share/licenses/go4/Go4License.txt"
#install the desktop file
echo "
[Desktop Entry]
Name=${_PKGNAME}
Comment=${pkgdesc}
- Exec=${pkgname}
+ Exec=go4
Icon=xchm-32
Terminal=false
Type=Application