summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhashworks2020-04-22 12:48:47 +0200
committerhashworks2020-04-22 12:48:47 +0200
commit239c46dde147ccf59b25c46f7b212c87d0cabe6a (patch)
tree4d52173f1547013ff6a2ee284d387c9c7797384b /PKGBUILD
parent40905a639f59941ed1f9b98a3912446bfc97cfa7 (diff)
downloadaur-239c46dde147ccf59b25c46f7b212c87d0cabe6a.tar.gz
Use git tag versioning
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83158117150a..c7f13db4c2c8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=goaccess-git
pkgrel=1
-pkgver=r2991.906e048
+pkgver=v0.8.r2629.ge0385cc
pkgdesc='GoAccess is a real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.'
url='https://goaccess.io'
license=('MIT')
@@ -17,7 +17,7 @@ md5sums=('SKIP')
pkgver() {
cd "goaccess"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {