summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhashworks2020-06-08 17:56:04 +0200
committerhashworks2020-06-08 17:56:04 +0200
commit4d7651e386fc5cf1d632f9f4cfa792bc7f4f343d (patch)
tree0730f217bf7847932ee89ea989a17ba7865b3770 /PKGBUILD
parentf4904998f2f20b8f8d424652e3ec7f79bfe588f5 (diff)
downloadaur-4d7651e386fc5cf1d632f9f4cfa792bc7f4f343d.tar.gz
Drop leading "v" in pkgver
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2d8891e7007..7b624daf7ced 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: hashworks <mail@hashworks.net>
pkgname=goaccess-git
+_pkgname="${pkgname%-git}"
pkgrel=1
-pkgver=v1.4.r20.gd6fb1252
+pkgver=1.4.r20.gd6fb1252
pkgdesc='A real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.'
url='https://goaccess.io'
license=('MIT')
arch=('x86_64')
-conflicts=('goaccess')
-provides=('goaccess')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
depends=('ncurses' 'libmaxminddb' 'openssl')
optdepends=('geoip2-database: for geoip support')
makedepends=('git')
@@ -17,19 +18,19 @@ source=('git+https://github.com/allinurl/goaccess.git')
sha256sums=('SKIP')
pkgver() {
- cd "goaccess"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "goaccess"
+ cd "${_pkgname}"
autoreconf -fiv
./configure --enable-geoip=mmdb --enable-utf8 --with-openssl --prefix=/usr --sysconfdir=/etc
make
}
package() {
- cd "goaccess"
+ cd "${_pkgname}"
install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
make prefix="$pkgdir/usr" sysconfdir="$pkgdir/etc" install
}