summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsg3des2017-02-04 23:15:33 +0300
committersg3des2017-02-04 23:15:33 +0300
commitabc4fc79ca3beae0ca236dcf486f8d0db9b13a89 (patch)
tree7d3b481d566a7a6a22e9dd28cb9e2b071505cb14 /PKGBUILD
downloadaur-abc4fc79ca3beae0ca236dcf486f8d0db9b13a89.tar.gz
try to aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23568686dd19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: sg3des <sg3des@gmail.com>
+
+pkgname=goatee
+pkgver=1
+pkgrel=1
+pkgdesc='lightwieght gtk2 text/hex editor written on Go'
+arch=('i686' 'x86_64')
+url='https://github.com/sg3des/goatee'
+license=('GPL')
+depends=('gtk2' 'gtksourceview2')
+makedepends=('git' 'go')
+source=("git://github.com/sg3des/goatee.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ GOPATH="$srcdir" go get -v ./...
+ GOPATH="$srcdir" go build -v -o $pkgname
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file