summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Gregoratto2019-01-11 22:21:22 +1100
committerStephen Gregoratto2019-01-11 22:21:22 +1100
commit1c50c16df984717ba52160fb7c59b1f1f98fb6ca (patch)
tree1a62d6200211e3078ede242df7a5ee147d42d09b /PKGBUILD
parent06ba67764ac1afe143ec6aa6621e111f40fda8a2 (diff)
downloadaur-1c50c16df984717ba52160fb7c59b1f1f98fb6ca.tar.gz
Update to 1.2.0, fix PKGBUILD formatting.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2617af75ce03..f9ac9a11442b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
pkgname=goawk
-pkgver=1.1.5
+pkgver=1.2.0
pkgrel=1
pkgdesc="AWK interpreter written in go"
url="https://github.com/benhoyt/goawk"
@@ -8,23 +8,23 @@ license=('MIT')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
makedepends=('go-pie')
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('56ff6e0f72b5481431e65d4a46ed39f1bae26e52126532e23f8d9333ac42454e')
+sha256sums=('e09f4b6689429271cdcc47f7d4a690999336fbac93db963dc90dd4d00834e314')
build() {
- cd "${pkgname}-${pkgver}"
- go build \
- -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
- -ldflags "-extldflags ${LDFLAGS}" \
- -o "${pkgname}" .
+ cd "${pkgname}-${pkgver}"
+ go build \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ -o "${pkgname}" .
}
check() {
- cd "${pkgname}-${pkgver}"
- go test ./...
+ cd "${pkgname}-${pkgver}"
+ go test ./...
}
package() {
- install -Dm755 "${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${pkgname}-${pkgver}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+ install -Dm755 "${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}-${pkgver}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
}