summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-27 19:06:15 +0200
committerGoliathLabs2020-05-27 19:06:15 +0200
commitd29e0a0c09ec7587c195e0b69c8bc25831656ef5 (patch)
tree2edf69d13b57b0b7d7ba0602e69cdccf9796e34d /PKGBUILD
parentff61a3fa656e6efbdc548be1712ad8167b77a172 (diff)
downloadaur-d29e0a0c09ec7587c195e0b69c8bc25831656ef5.tar.gz
Updated: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50e188796a6b..888455b1c822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgname=gobject-introspection
pkgbase="${_pkgname}-git"
pkgname=(${_pkgname}-git ${_pkgname}-runtime-git)
pkgver=1.64.0+47+ge7c17469
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Introspection system for GObject-based libraries (Git)"
url="https://wiki.gnome.org/Projects/GObjectIntrospection"
@@ -35,20 +35,20 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- arch-meson $_pkgname build \
+ arch-meson $srcdir/$_pkgname build \
-D gtk_doc=true \
-D glib_src_dir="$srcdir/glib"
ninja -C build
}
check() {
- meson test -C build
+ meson test -C $srcdir/$_pkgname/build
}
package_gobject-introspection-git() {
depends+=("gobject-introspection-runtime-git=$pkgver-$pkgrel")
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C $srcdir/$_pkgname/build
python -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"
python -O -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"