summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Jackson2019-12-10 22:17:18 +1100
committerAndrew Jackson2019-12-10 22:17:18 +1100
commit78035326828bdbdb16d0031aef8ab2f6bf7fc481 (patch)
tree1614162ac7cfaba99cba02a1627b7bf1d6c1d0d4 /PKGBUILD
downloadaur-gocryptotrader-git.tar.gz
CREATED PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b6171fe2baa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Andrew Jackson <andrew@thrasher.io>
+pkgname=gocryptotrader-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r1105.473092a6
+pkgrel=1
+pkgdesc='A cryptocurrency trading bot supporting multiple exchanges written in Golang.'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/thrasher-corp/gocryptotrader"
+license=('MIT')
+makedepends=('git' 'go' 'make')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+
+source=('gocryptotrader::git+https://github.com/thrasher-corp/gocryptotrader')
+noextract=()
+md5sums=('SKIP')
+md5sums=('SKIP')
+
+
+
+pkgver() {
+ cd "$srcdir/gocryptotrader"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/gocryptotrader"
+ make build
+}
+
+
+package() {
+ cd "$srcdir/gocryptotrader"
+ install -Dm644 config_example.json "${pkgdir}/usr/share/gocryptotrader/config.json"
+ printf "Config example has been copied to /usr/share/gocryptotrader/config.json"
+ make install
+}