summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarvin Dalheimer2018-03-04 12:20:13 +0100
committerMarvin Dalheimer2018-03-04 12:20:13 +0100
commit5d9b5b88723d07cae72d93fa8d74638a7d30a8e3 (patch)
treef262e9f5a6eb890ae15233d0043799bd2caf2780 /PKGBUILD
parentf9501d6a437b33df897b9194214106575cca9c4c (diff)
downloadaur-5d9b5b88723d07cae72d93fa8d74638a7d30a8e3.tar.gz
Updated to Godot 3.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c052830e8d0..90c4b182dbd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Marvin Dalheimer <me@marvin-dalheimer.de>
pkgname=godot-mono-bin
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
arch=("x86_64")
url="https://www.godotengine.org"
license=('MIT')
provides=("godot-mono-bin")
-conflicts=("godot" "godot-git")
-replaces=("godot" "godot-git")
-depends=("mono>=5.4.0")
-optdepends=("msbuild-bin")
+conflicts=("godot-mono")
+depends=("mono>=5.4.0" "msbuild-stable")
+optdepends=("dotnet-sdk")
source=("godot-mono.desktop" "icons.tar.gz")
source_x86_64+=("$pkgname-$pkgver.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_64.zip")
md5sums=('c8ba9f7656b2c2db9a3ec385b3848bf5'
'281c83d55c6a4d39fb9710e6f143bc5a')
-md5sums_x86_64=('24ad184f35aa393c2ba7cea557fde1e2')
+md5sums_x86_64=('602c755b8d837477d40169b6ddc47592')
package() {
mkdir -p "$pkgdir/opt/$pkgname"
@@ -27,7 +26,6 @@ package() {
cp "$srcdir/godot-mono.desktop" "$pkgdir/usr/share/applications/godot-mono.desktop"
cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
- cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/gnome"
chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v"$pkgver"-stable_mono_x11.64"