summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJorge Araya Navarro2018-01-31 12:28:20 -0600
committerJorge Araya Navarro2018-01-31 12:28:20 -0600
commit1a7f1d6e1706ec0523d0868e128f38f1c320d9af (patch)
tree1d117fefa40cbd06dd18c7a755fd29cdfc468f3b /PKGBUILD
parent10c938dfd48efc138cd1662c5717c5ef76146773 (diff)
downloadaur-1a7f1d6e1706ec0523d0868e128f38f1c320d9af.tar.gz
Use GCC instead of LLVM
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 754f682fc890..86f935997ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=godot-pulse
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine, with pulseaudio"
url="http://www.godotengine.org"
license=('MIT')
arch=('i686' 'x86_64')
-makedepends=('scons' 'clang' 'yasm')
+makedepends=('scons' 'gcc' 'yasm')
depends=('libxcursor' 'libxinerama' 'freetype2' 'pulseaudio' 'libxrandr' 'libxi' 'libglvnd')
conflicts=("godot-git" "godot")
_arch=''
@@ -40,7 +40,7 @@ build() {
scons platform=x11 \
tools=yes \
target=release_debug \
- use_llvm=yes \
+ use_llvm=no \
builtin_openssl=yes \
colored=yes \
pulseaudio=yes bits=${_arch} -j $((`nproc`+1))
@@ -55,6 +55,6 @@ package() {
cd "${srcdir}"/${pkgname%-*}-${pkgver}-stable
- install -D -m755 bin/godot.x11.opt.tools.${_arch}.llvm "${pkgdir}"/usr/bin/godot
+ install -D -m755 bin/godot.x11.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot/LICENSE
}