summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJorge Araya Navarro2018-01-30 11:47:58 -0600
committerJorge Araya Navarro2018-01-30 11:47:58 -0600
commitbf98b59c3f9a7a58992001daf8aeed0f7470c04a (patch)
tree934b31ade36303512bb45a78648730d25c0d73ff /PKGBUILD
parente3233efe6d786121daea12eb09a2d55a4260e83a (diff)
downloadaur-bf98b59c3f9a7a58992001daf8aeed0f7470c04a.tar.gz
Updates version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6099b194cc98..754f682fc890 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Matthew Bentley <matthew@mtbentley.us>
pkgname=godot-pulse
-pkgver=2.1.4
-pkgrel=3
+pkgver=3.0
+pkgrel=1
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine, with pulseaudio"
url="http://www.godotengine.org"
license=('MIT')
arch=('i686' 'x86_64')
-makedepends=('scons' 'clang' 'glu')
-depends=('libxcursor' 'libxinerama' 'freetype2' 'pulseaudio' 'zlib' 'libxrandr')
+makedepends=('scons' 'clang' 'yasm')
+depends=('libxcursor' 'libxinerama' 'freetype2' 'pulseaudio' 'libxrandr' 'libxi' 'libglvnd')
conflicts=("godot-git" "godot")
_arch=''
if test "$CARCH" == x86_64; then
@@ -23,16 +23,13 @@ source=(
"https://github.com/godotengine/godot/archive/${pkgver}-stable.tar.gz"
godot.desktop
icon.png
- py2to3.patch
)
-sha256sums=('07cf3b01367d5ea53805f144bc60711bd79efb53f1f88d57d6a706e6944de8d7'
+sha256sums=('cc4392dbc9e7aa9c33c10c652299fe5c2e160921a514b18731eca860931117ca'
'd2f5ae30b8c0c3fd8a20a451d34e9e9d0ba1b60a39b1f68484a9a74227c83822'
- 'b6bb8e42625414303cf7608f08fe63bd3267486bf7a96586ebab05ade5189785'
- '713a953892b85597bc9dd3385fbeb2b3d4338fb3fc9738bb1901de6129ee909e')
+ 'b6bb8e42625414303cf7608f08fe63bd3267486bf7a96586ebab05ade5189785')
prepare() {
cd "${srcdir}"/${pkgname%-*}-${pkgver}-stable
- patch -Np1 -i "${srcdir}/py2to3.patch"
}
build() {