summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2023-03-10 14:12:20 -0600
committerHurricanePootis2023-03-10 14:12:20 -0600
commit5d5601a157347a9d2e7758308645886caee701bd (patch)
tree4b395d3a5a011497bfda3c5e20fccc31e06dd617 /PKGBUILD
downloadaur-5d5601a157347a9d2e7758308645886caee701bd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33daf7f3fdac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+_pkgname=godot
+pkgname=godot3-bin
+pkgver=3.5.2
+pkgrel=1
+pkgdesc="Advanced cross-platform 2D and 3D game engine (3.X Branch)"
+arch=("x86_64")
+url='https://godotengine.org'
+license=('MIT')
+depends=(libglvnd libxcursor libxi libxinerama libxrandr) # Depends() is small due to godot binary static linking libraries
+optdepends=(pipewire-alsa pipewire-pulse)
+provides=("godot")
+conflicts=("godot")
+source=("https://github.com/godotengine/godot/releases/download/${pkgver}-stable/Godot_v${pkgver}-stable_x11.64.zip"
+ "desktop.tar.xz") #desktop.tar.xz is taken from godot3, since the godot binary doesn't come with any files for desktop integration, nor the man pages
+sha256sums=('fe2548c59e112a7495bf6a8b42b44ec19c80ea59d60208c185574bed17768044'
+ '2c969b88ac07d96ad1c72b06ac5b0ce1307ebe6a6864a9885ece16b88c014805')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 Godot_v$pkgver-stable_x11.64 ${pkgdir}/opt/godot3-bin/Godot_v$pkgver-stable_x11.64
+ mkdir -p "${pkgdir}/usr/share" && mkdir -p "${pkgdir}/usr/bin"
+ for folder in {applications,licenses,man,mime,pixmaps};
+ do
+ cp -r "${srcdir}/share/$folder" "${pkgdir}/usr/share/$folder"
+ done
+
+ install -Dm755 bin/godot ${pkgdir}/usr/bin/godot
+}