summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-04-28 17:13:16 +0800
committerzxp198210052023-04-28 17:13:16 +0800
commit9d1d48f3d74c16819120858bba114d560bacceb5 (patch)
tree3d2084a86e90b21840b30e901f9dd8c33ba21e16 /PKGBUILD
parent1ddb5ba46e180551474154ef9198081370c822ef (diff)
downloadaur-9d1d48f3d74c16819120858bba114d560bacceb5.tar.gz
optimized code
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 331491a48c30..93492938ecc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: katt <magunasu.b97@gmail.com>
-
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: katt <magunasu.b97@gmail.com>
pkgname=godotpcktool-bin
pkgver=1.8
-pkgrel=2
+pkgrel=3
pkgdesc='Standalone tool for extracting and creating Godot .pck files'
arch=(x86_64)
-url=https://github.com/hhyyrylainen/GodotPckTool
-license=(MIT)
-depends=(glibc)
-provides=(${pkgname%-bin})
-conflicts=(${pkgname%-bin})
-source=("${pkgname%-bin}-${pkgver}"::"${url}/releases/download/v${pkgver}/${pkgname%-bin}"
- "${pkgname}-${pkgver}-LICENSE"::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/v1.8/LICENSE)
+url="https://github.com/hhyyrylainen/GodotPckTool"
+license=('MIT')
+depends=('glibc')
+provides=()
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}::${url}/releases/download/v${pkgver}/${pkgname%-bin}"
+ "LICENSE::${url}/raw/master/LICENSE")
sha256sums=('7e3a35c7abe7041b12b9b5f6b51b717bdb0d38ce466a11b05551ed489a717948'
'9713a591001e5fa3d46f2af637b12c35859247a5fe8788abc794fff89f5d5fb8')
package() {
- install -Dm755 "${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+ install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file