summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2020-12-26 17:32:55 +0100
committerMagnus Boman2020-12-26 17:32:55 +0100
commite886c458bdcc1ef9a99c6c32e440f8e255eb3561 (patch)
tree0425081185bcbcd25aff6889e83bd5da2db38205 /PKGBUILD
downloadaur-e886c458bdcc1ef9a99c6c32e440f8e255eb3561.tar.gz
Initial upload: godotpcktool-bin 1.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dede0fb1ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
+pkgname=godotpcktool-bin
+pkgver=1.4
+pkgrel=1
+pkgdesc='Standalone tool for extracting and creating Godot .pck files'
+arch=(x86_64)
+url=https://github.com/hhyyrylainen/GodotPckTool
+license=(MIT)
+depends=(glibc)
+provides=(${pkgname%-bin})
+conflicts=(${pkgname%-bin})
+source=("${pkgname%-bin}-${pkgver}"::"${url}/releases/download/v${pkgver}/${pkgname%-bin}"
+ "${pkgname}-LICENSE"::https://raw.githubusercontent.com/hhyyrylainen/GodotPckTool/master/LICENSE)
+sha256sums=('f2f38c1f651b4b3dc09c25064142d4e4b13d51d392f996ffe2727b599ff0e732'
+ '2991d0067840841a14a5971d4cc9a2c3c82496ae52fa402919d17f1ce95a92fd')
+
+package() {
+ install -Dm755 "${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${pkgname}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}