summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoshless2020-07-27 23:34:59 +0200
committerRoshless2020-07-27 23:34:59 +0200
commit53804bf52cf069c29ce65a089361ff3e326359e8 (patch)
treee3101fc9f515ad67b42096a0d9e14ea41493d53b /PKGBUILD
parent8cd77547774dcd8b9de122dc9b85cd208356be59 (diff)
downloadaur-53804bf52cf069c29ce65a089361ff3e326359e8.tar.gz
upgpkg: gofu 1.1.2-3
Add build options etc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 324d2449216c..49605b00b661 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Roshless <pkg@roshless.com>
pkgname=gofu
-pkgrel=2
+pkgrel=3
pkgver=1.1.2
pkgdesc='Simple file share service in go'
url='https://git.roshless.me/~roshless/gofu'
@@ -19,9 +19,12 @@ source=("https://git.roshless.me/~roshless/$pkgname/archive/$pkgver.tar.gz"
build() {
cd $pkgname-$pkgver
- go build \
- -trimpath \
- -o $pkgname .
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o $pkgname .
}
package() {