summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoJoS2015-06-19 16:01:24 +0200
committerJoJoS2015-06-21 00:16:32 +0200
commit1d532cc5fad2d7de8ba1d97f3042c73cfef99738 (patch)
tree0b2d1be6556fe238e73bcde29f50b9cdb06e4d94 /PKGBUILD
downloadaur-gog-apotheon.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ff406cc4bf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : JoJos
+
+pkgname=gog-apotheon
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="The Gods of Olympus have abandoned humanity, leaving you to perish without their benevolence. GOG linux game package required!"
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/apotheon"
+license=("custom")
+groups=("games")
+source=("local://gog_apotheon_${pkgver}.tar.gz" "gog-apotheon")
+md5sums=('13432c627e378516474895eafab39ccb'
+ '08eee547be3e5dc1f43c6937fca5bc6e')
+depends=(libgl libx11 libxext desktop-file-utils)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/apotheon
+ cp -r "${srcdir}"/Apotheon/* "${pkgdir}"/opt/gog/apotheon
+ install -Dm644 "${srcdir}"/Apotheon/support/gog-apotheon-primary.desktop "${pkgdir}"/usr/share/applications/gog-apotheon.desktop
+ install -Dm644 "${srcdir}"/Apotheon/support/gog-apotheon.png "${pkgdir}"/usr/share/pixmaps/gog-apotheon.png
+ install -Dm644 "${srcdir}"/Apotheon/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-apotheon" "${pkgdir}/usr/bin/gog-apotheon"
+}