summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjapernilater2015-08-07 23:09:49 -0500
committerjapernilater2015-08-07 23:09:49 -0500
commitdd9ff36dde0e96cd25e63454f39a562810e2afaa (patch)
tree89680bcbe50335ccd9007dca54ccb3006eeb58ed /PKGBUILD
downloadaur-dd9ff36dde0e96cd25e63454f39a562810e2afaa.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2453d6c4312d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jeff Youdontneedtoknow <jeffpublicjr at gmail dot com>
+
+pkgname=gog-flatout
+pkgver=1.0.0.7
+pkgrel=2
+pkgdesc="Thrilling combination of high-octane racing, smash-em-up demolition derby action and death defying stunts propelling the driver through the windshield!"
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/flatout"
+license=("custom")
+groups=("games")
+source=("local://gog_flatout_${pkgver}.tar.gz" "gog-flatout")
+sha256sums=('54412a5920cce062125214ed0fce52fbcae058a97e90642cab8f11c5326b490f'
+ 'adc728b81188d3daeb7bca130dc591a73875a41e273488d0351534334a0ce3c5')
+depends=(libgl libx11 libxext desktop-file-utils)
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/gog/flatout
+ cp -r "${srcdir}"/FlatOut/* "${pkgdir}"/usr/share/gog/flatout
+ install -Dm644 "${srcdir}"/FlatOut/support/gog-flatout-primary.desktop "${pkgdir}"/usr/share/applications/gog-flatout.desktop
+ install -Dm644 "${srcdir}"/FlatOut/support/gog-flatout.png "${pkgdir}"/usr/share/pixmaps/gog-flatout.png
+ install -Dm644 "${srcdir}"/FlatOut/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-flatout" "${pkgdir}/usr/bin/gog-flatout"
+}