summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilippe Cherel2017-07-02 16:28:49 +0200
committerPhilippe Cherel2017-07-02 16:28:49 +0200
commit524a0965cc1ce7bc1db2cba8d41ecb6f4812810a (patch)
treed8ad77df8ea24a44e200a0b75ac494083f5fe6c5 /PKGBUILD
parent183c3979cdaa5ea6fb5863164a6a8e75b8b642c7 (diff)
downloadaur-gog-quest-for-infamy.tar.gz
upgrade to latest version and corrected PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 088433fea164..118a0669f34f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: Philippe Cherel <philippe dot cherel at mayenne dot org>
pkgname=gog-quest-for-infamy
+_pkgname=quest-for-infamy
_original="Quest For Infamy"
-pkgver=1.1.0.4
-pkgrel=3
-pkgdesc="Quest For Infamy is a role-playing adventure game where you assume the identity of Mr. Roehm - a scoundrel who is on the run from his latest scrape. GOG Version. Linux native."
+pkgver=2.2.0.6
+pkgrel=1
+pkgdesc=" Quest For Infamy is a role-playing adventure game where you assume the identity of Mr. Roehm - a scoundrel who is on the run from his latest scrape. GOG Version. Linux native."
arch=('i686' 'x86_64')
url="http://www.gog.com/game/quest_for_infamy"
license=('custom')
-groups=('games')
-source=("local://gog_quest_for_infamy_${pkgver}.tar.gz"
- "${pkgname}")
+depends_i686=('bzip2' 'freetype2' 'gcc-libs' 'glib2' 'glibc' 'graphite' 'harfbuzz' 'libpng' 'libx11' 'libxau' 'libxcb' 'libxcursor' 'libxdmcp' 'libxext' 'libxfixes' 'libxpm' 'libxrender' 'libxxf86vm' 'pcre' 'zlib')
+depends_x86_64=('bzip2' 'freetype2' 'gcc-libs' 'gcc-libs-multilib' 'glib2' 'glibc' 'graphite' 'harfbuzz' 'libpng' 'libx11' 'libxau' 'libxcb' 'libxcursor' 'libxdmcp' 'libxext' 'libxfixes' 'libxpm' 'libxrender' 'libxxf86vm' 'pcre' 'zlib')
+DLAGENTS+=("gog::/usr/bin/echo Could not find %u. Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT in /etc/makepkg.conf.")
+source=("gog://gog_quest_for_infamy_$pkgver.sh"
+ "${pkgname}"
+ "$pkgname.desktop")
PKGEXT=".pkg.tar"
-sha256sums=('2e1e05313e3c0db48831e284075019c18d9245f968ca1177ce82b6375e85bf00'
- '8e226ffb62292c57e4bc76eb0e565f272e6d9d2283541cef7648e3abbcf829de')
+sha256sums=('1f29436280cf671dede6237d067f1584d6dd085a1ac6d8d9b2d7c2839d95eff6'
+ 'e23d684611eec676efad1fac3764d44c2e1900cf84d0783e78602981e31f9f60'
+ '4f630ef3219c083e305976325934088e6a626ecad176d6769aeba8e55404b465')
package() {
- mkdir -p "${pkgdir}"/opt/gog/${pkgname}
- cp -r "${srcdir}"/"${_original}"/* "${pkgdir}"/opt/gog/${pkgname}
- chown -R :games "${pkgdir}"/opt/gog/${pkgname}
- chmod 775 "${pkgdir}"/opt/gog/${pkgname}/game
- chmod 644 "${pkgdir}"/opt/gog/${pkgname}/game/acsetup.cfg
- chmod 644 "${pkgdir}"/opt/gog/${pkgname}/game/agsgame.dat
- install -Dm644 "${srcdir}"/"${_original}"/support/${pkgname}-primary.desktop "${pkgdir}"/usr/share/applications/${pkgname}-primary.desktop
- install -Dm644 "${srcdir}"/"${_original}"/support/${pkgname}.png "${pkgdir}"/usr/share/pixmaps/${pkgname}.png
- install -Dm644 "${srcdir}"/"${_original}"/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
- install -Dm755 "${srcdir}"/$pkgname "${pkgdir}"/usr/bin/${pkgname}
+ _pkgdir="$pkgdir/opt/gog/$_pkgname"
+ mkdir -p "$pkgdir"/opt/gog/$_pkgname
+ cp -r data/noarch/* "$_pkgdir"
+ chmod 775 "$pkgdir"/opt/gog/$_pkgname/game
+ chmod 644 "$pkgdir"/opt/gog/$_pkgname/game/acsetup.cfg
+ chmod 644 "$pkgdir"/opt/gog/$_pkgname/game/agsgame.dat
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/hicolor/256x256/$pkgname.png"
+ install -Dm644 data/noarch/docs/End\ User\ License\ Agreement.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}