summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-06-12 12:07:03 +1200
committercaltlgin2020-06-12 12:07:03 +1200
commit6085707e8d8d3959543383b09c2a4655eca669a0 (patch)
treebecc9a0a6eb337d34b02fc77a5546a07ccdc80f9 /PKGBUILD
downloadaur-6085707e8d8d3959543383b09c2a4655eca669a0.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..848b3e436211
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=gogextract
+pkgname=${_pkgname}-git
+pkgver=r2.6601b32
+pkgrel=1
+pkgdesc="Unpack GOG Linux installers"
+arch=('any')
+url="https://github.com/Yepoleb/${_pkgname}"
+license=('MIT')
+source=("git+${url}.git")
+depends=('python')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 "${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+} \ No newline at end of file