summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Vikstrom2015-09-10 11:21:28 +0200
committerSimon Vikstrom2015-09-10 11:24:10 +0200
commit345932f0b2b13d8c094ddcb362f9ea1a857c0f1d (patch)
tree7b38d3a6bd815ae4c06bae91fc21066feb370037 /PKGBUILD
downloadaur-345932f0b2b13d8c094ddcb362f9ea1a857c0f1d.tar.gz
First package of goiardi chef-server
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f691f2956a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=goiardi
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="A Chef server written in Go, able to run entirely in memory, with optional persistence with saving the in-memory data to disk or using MySQL or Postgres as the data storage backend"
+arch=('x86_64')
+license=('Apache 2.0')
+url="http://goiardi.gl/"
+source=(
+ https://github.com/ctdk/goiardi/releases/download/v$pkgver/goiardi-$pkgver-linux-amd64
+ goiardi.service
+ )
+
+md5sums=('5fbd475a3f8c64681f9ace1f53212f78'
+ 'SKIP'
+ )
+
+package() {
+ cd $srcdir
+ install -D -m755 $srcdir/goiardi-$pkgver-linux-amd64 $pkgdir/usr/bin/goiardi
+ install -D -m644 "${srcdir}/goiardi.service" "${pkgdir}/usr/lib/systemd/system/goiardi.service"
+}