summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2021-06-22 21:33:54 +0200
committerml2021-06-22 21:33:54 +0200
commit0537688d1f7d2fa54242802ec705922dfaa10222 (patch)
tree451d070f691dd31298f3bf5be2332b6adc888ec0 /PKGBUILD
parent520184b47f60792e19efb825ffa8209d707b43cb (diff)
downloadaur-0537688d1f7d2fa54242802ec705922dfaa10222.tar.gz
updpkg: golang-mockery 2.9.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a90093f1a4e..9ee33be06aab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <>
pkgname=golang-mockery
_pkgname=${pkgname##golang-}
-pkgver=2.7.4
+pkgver=2.9.0
pkgrel=1
pkgdesc='A mock code autogenerator for golang'
arch=('x86_64')
@@ -9,27 +9,27 @@ url='https://github.com/vektra/mockery'
license=('BSD')
depends=('glibc')
makedepends=('go')
-source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('22297f811490d4eac93f26b129ed3b58a9d5b42893496a32acce0b4756676870')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('bd1d21630b3ff1b5a9b0b5fe402e7d48bef453c96c119f276ed1bc1569e410fd')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -modcacherw -mod=readonly -trimpath'
- go build -o bin/${_pkgname} -ldflags "-linkmode=external -X github.com/vektra/mockery/v2/pkg/config.SemVer=${pkgver}"
+ export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+ go build -o bin/"$_pkgname" -ldflags "-linkmode=external -X github.com/vektra/mockery/v2/pkg/config.SemVer=$pkgver"
}
check() {
- cd "${_pkgname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
go test ./...
}
package() {
- cd "${_pkgname}-${pkgver}"
- install -Dm755 bin/${_pkgname} -t "${pkgdir}/usr/bin"
- install -Dm755 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "$_pkgname-$pkgver"
+ install -Dm755 bin/"$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm755 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}