summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-04-29 03:36:51 +0200
committerml2020-04-29 03:36:51 +0200
commit79446bf0d6b16c4cdc1758364fcba56aad1d1a6f (patch)
tree9603b4f76f3e4d9c154971c6c21cfa722600745f /PKGBUILD
parent7833fe0937a2d5f09e9bdd7f1b7b074f83802584 (diff)
downloadaur-79446bf0d6b16c4cdc1758364fcba56aad1d1a6f.tar.gz
upgpkg: golangci-lint 1.25.1-4
Another one
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e6cd9c51426..06ab81c060e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=golangci-lint
pkgdesc="Linters Runner for Go. 5x faster than gometalinter."
pkgver=1.25.1
-pkgrel=3
+pkgrel=4
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url='https://github.com/golangci/golangci-lint'
license=('GPL3')
@@ -31,10 +31,12 @@ build() {
}
check() {
+ env | sort
+ exit 1
cd "${pkgname}-${pkgver}"
# some tests build the binary and overwrite our build
chmod 555 "$pkgname" # canary
- GOLANGCI_LINT_INSTALLED=true go test -a -short ./...
+ GOLANGCI_LINT_INSTALLED=true go test ./...
}
package() {