summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-04-29 00:50:38 +0200
committerml2020-04-29 00:50:38 +0200
commitee274e5abbbf48484ffb0d7e7417cfcad2128155 (patch)
treedda19e9a533c92aa5f15ec295126bbcb1399abaa /PKGBUILD
parent946b5abf964eeaed695b8a04de1c1a1f7258d0bd (diff)
downloadaur-ee274e5abbbf48484ffb0d7e7417cfcad2128155.tar.gz
updpkg: golangci-lint 1.25.1-2
Attempt to fix weird test failure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01709b386b5e..527f82ad0da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=golangci-lint
pkgdesc="Linters Runner for Go. 5x faster than gometalinter."
pkgver=1.25.1
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url='https://github.com/golangci/golangci-lint'
license=('GPL3')
@@ -11,6 +11,11 @@ makedepends=('git' 'go' 'gzip')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/golangci/golangci-lint/archive/v${pkgver}.tar.gz")
sha256sums=('034440e00f81d1b5adfe5e39bceb2f0b9cb19066195a61e750a4982bbe512cf3')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ go mod download
+}
+
build() {
export CGO_LDFLAGS="${LDFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -29,7 +34,7 @@ check() {
cd "${pkgname}-${pkgver}"
# some tests build the binary and overwrite our build
chmod 555 "$pkgname" # canary
- GOLANGCI_LINT_INSTALLED=true go test ./...
+ GOLANGCI_LINT_CACHE="${srcdir}/golangci-lint-cache" GOLANGCI_LINT_INSTALLED=true go test -short ./...
}
package() {